Skip to content

Cisco Q-in-Q Sample Configuration

January 10, 2011

Q-in-Q encapsulation digunakan untuk routing VLAN antar PE atau sering disebut Vlan dan Vlan. berikut adalah contoh konfigurasinya :

user1 —– sw-a — PE-sw1==== PE-sw2 —sw-b –user2

note :
user1 192.168.10.1/24
user2 192.168.10.2/24

sw-a
########################
interface FastEthernet0/1
description Connection to user1
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
description Trunk
switchport trunk allowed vlan 20
switchport mode trunk

PE-sw1
#########################
interface FastEthernet2/0/1
description Connection to sw-a
switchport access vlan 100
switchport mode dot1q-tunnel
no cdp enable
interface FastEthernet2/0/24
description Connection to PE-sw2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk

PE-sw2
###########################
interface FastEthernet2/0/1
description Connection to sw-b
switchport access vlan 100
switchport mode dot1q-tunnel
no cdp enable
interface FastEthernet2/0/24
description Connection to PE-sw1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk

sw-b
##########################
interface FastEthernet0/1
description Connection to user1
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
description Trunk
switchport trunk allowed vlan 20
switchport mode trunk

fyi, yg paling penting untuk q-in-q adalah konfigurasi PE Switch yg menuju switch user, yaitu : switchport trunk encapsulation dot1q

Smoga bermanfaat :D

From → Linux

4 Comments
  1. suherman permalink

    Hi, saya baru mengetahui tentang QinQ :
    1. bagaimana jika di sisi user ada banyak VLAN, apakah interface yang ke arah PE di allowed semua VLAN tersebut?

    2. apakah ada parameter lainnya untuk Cisco, jika QinQ ini menggunakan ethertype yang mana ?

    Thanks in advance…

    • vade permalink

      1. Yup, di-allow smw vlan yg ingin dilewatkan

      2. untuk pertanyaan ini lebih baik refer ke cisco.com aja ya

  2. ihan permalink

    mau tanya pak,, kalau Q-in-Q sendiri itu kepanjangan nya apa ya ? saya hanya tau maksudnya saja…

    • vade permalink

      itu bukan singkatan, hanya terminologi/standar dalam networking

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: