Skip to content

Automatic Failover dengan Mikrotik

September 23, 2008

Setelah posting di forum tidak ada  yang reply, akhirnya script automatic failover di MT V.3x berhasil saya terapkan.
Script ini diambil dari sini, akan tetapi saya rubah sedikit, karena belum jalan di mikrotik saya.
Sebelumnya saya akan terangkan skenario-nya,

ISP 1 ————– |            |
                            |  Mikrotik | ========= LAN
ISP 2 ————– |            |

Sebuah Mikrotik terhubung dengan 2 ISP (WAN), ISP 1 sebagain main link, sedangkan ISP 2 sebagai backup link. Bila ISP 1 down, maka routing internet akan ke ISP 2, jika ISP 1 up kembali, routing kembali ke semula.

Setelah semua dikonfigurasi secara standar, Berikut adalah step2-nya :

1. Beri nilai 1 untuk distance di routing utama (main link), dan nilai 2 untuk routing backup.
2. Define IP Public luar yang bisa di monitoring, misal saya ambil 172.16.64.13 sebagai ip netwatch saya, kemudian tmbahkan routing ke ip tersebut melalui main link.

Misal :

ISP 1 = ADSL
ISP 2 = Cable/IM2

3. Tambahkan script berikut yang berfungsi script fail over dan ip monitoring :

==============================================================

/system script add name=”failover” source={
:if ([/ip route get [/ip route find comment=”utama”] disabled]=”yes”) do={/ip route enable [/ip route find comment=”utama”]} else={/ip route disable [/ip route find comment=”utama”]}

/system script add name=”back2main” source={
:if ([/ip route get [/ip route find comment=”utama”] disabled]=”yes”) do={/ip route enable [/ip route find comment=”utama”]}

/tool netwatch add host=172.16.64.13 interval=10s timeout=1s down-script=”failover”
/tool netwatch add host=172.16.64.13 interval=10s timeout=1s up-script=”back2main”

pemberian interval dan timeout silahkan disesuaikan dengan kebutuhan jaringan anda.

keterangan :

Monitoring ke ip 172.16.64.13 setiap 10 detik, bila dideteksi down maka failover script yang berfungsi untuk mendisable routing utama yang aktif, dan sebaliknya, bil ip tersebut up kembali maka mikrotik akan menjalan script back2main untuk meng-enable-kan routing utama.

Silahkan dicoba…..

From → Mikrotik

8 Comments
  1. boz..script klo mati di gtway utama oke langsung mati cuman dia ngga pindah ke gtway cadangan nya,nah klo gtway utama nyala lagi dia lngsung kembali ke gtway utama yang kurang dari scriptnya kenapa pas gtway utama mati ngga pindah ke gtway cadangan nya.mohon pencerahan.thanxz

  2. vade permalink

    coba disable script dulu dan lakukan secara manual. cabut kebel wan1, dan lihat apakah routing ke internet berpindah ke wan2 mas.
    kalo hal itu berjalan baik, test pake script mas….jangan lupa diperhatikan script, tool netwatch dan ip monitoring yang sudah di”fixed:-kan routingnya.
    Tq…selamat mencoba ya

  3. Eko Wibowo permalink

    Mas, apakah ini bisa diterapkan untuk private WAN (leased line)?
    Thanks

  4. Simon Thomas permalink

    Hi,

    Can someone please wirte this in english, I am not able to read your post

  5. vade permalink

    use google translate, but i tink the most important is the script.
    if you can read the script, you will understand about the configuration

  6. sebetulnya, tanpa netwatch dan script pun failover sudah bisa jalan,
    intinya hanya ada di distancenya saja.
    hanya netwatch dan script adalah supaya kita tau saja apa yang down, sebagai monitoring kita bersama saja.

  7. zar speedy permalink

    kalo aku:

    /ip route add gateway=124.xxx.xx.x check-gateway=ping
    /ip route add gateway=127.xxx.xx.x distance=2

    check-gateway=ping akan memastikan koneksi bahwa gateway pertama sebagai distance 1 aktif.
    ketika ping pada distance 1 gagal, maka gateway pertama pada distance 1 akan di-non aktifkan dan gateway yang kedua pada distance 2 akan melakukan backup.
    tetapi, ketika gateway pertama aktif lagi, maka otomatis kembali seperti semula.

    BTW…. script di atas mantab juga :)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: