Skip to content

Script and Scheduling in Mikrotik OS

May 28, 2008

Misalnya IP Address pelanggan yang telah kita set dan kita berikan src-nat IP publik
(diasumsikan tidak melewati proxy) di Mikrotik adalah : 172.168.1.0/30

1. Login ke Mikrotik OS Anda, lalu ketik :

system script

2. Ketik script untuk mematikan koneksi pelanggan ke arah publik:

add name=”pelanggan-off” \
policy=ftp,read,write,policy,winbox,password \
source={/ip firewall nat set [/ip firewall nat find \
src-address=172.168.1.0/30] disabled=yes}

3. Sedangkan script untuk menghidupkan koneksi pelanggan ke arah publik:

add name=”pelanggan-on” \
policy=ftp,read,write,policy,winbox,password \
source={/ip firewall nat set [/ip firewall nat find \
src-address=172.168.1.0/30] disabled=no}

4. Lalu, langkah terakhir adalah menentukan jam kapan pelanggan harus terkoneksi
ke publik (internet) atau mematikan IP publik pelanggan yang telah kita masukan
kedalam script tadi. Misalnya kita tentukan jam hidup koneksi pada pukul
09.00-14.30, sedangkan waktu matinya koneksi pada pukul 14.31 – 08.59. Cukup
kita panggil nama scriptnya didalam schedule :

/system scheduler

add name=hidup09-1430 start-time=09:00:00 \
interval=1d on-event=pelanggan-on

add name=mati1431-0859 start-time=14:31:00 \
interval=1d on-event=pelanggan-off

taken from :
http://mujie.blog.palangkaraya.net/2007/12/24/script-dan-schedule-di-mikrotik-os/#comment-26

From → Mikrotik

One Comment
  1. Bos, sorry udah pindah link ke http://mujie.blog.niwakarya.com/mikrotik/2007/12/24/script-dan-schedule-di-mikrotik-os.html .Server yang lama dah ga ada, soalnya dah saya dah pindah kerjaan mencoba mandiri. Dan blog pindahan itu saya host di tempat gratisan. Thanks sebelumnya :)

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: